BastEt 阅读(1434) 评论(0)
转自:
http://pastebin.com/9YGpCZ2F

Lua 5.1 API incompatibility with Lua 5.2 beta rc-2

==Removed==
LUA_GLOBALSINDEX (这个可能要用getglobal来了,)
LUA_ENVIRONINDEX
lua_getfenv
lua_setfenv
luaL_typerror
luaL_putchar
lua_yield

==Compat removed ==
luaI_openlib
luaL_getn
luaL_setn
lua_ref
lua_unref
lua_getref
lua_open
lua_getregistry
lua_getgccount
lua_Chunkreader
lua_Chunkwriter
luaL_reg

==Requires LUA_COMPAT_ALL==
lua_cpcall
lua_strlen
lua_objlen
lua_equal
lua_lessthan

==Signature changed==
lua_pushlstring
lua_pushstring

==Structure changed==
luaL_Buffer
lua_Debug

Other API changes are hidden by macros





发表评论
切换编辑模式